JxBrowser 5.0 - 5.2.1 (Chromium 39)

Java Applets in these versions are supported. You can load web pages with embedded Java Applets.


JxBrowser 5.3 - 6.3 (Chromium 43)

In 5.3 version we switched on Chromium 43 that by default doesn't support Java Applet (NPAPI) plugins. But you can enable support of NPAPI plugins using the following Chromium switcher:

BrowserPreferences.setChromiumSwitches("--enable-npapi");
Browser browser = new Browser();

JxBrowser 6.4 and higher (Chromium 49+)

In 6.4 version we switched on Chromium 49 that doesn't support Java Applet (NPAPI) plugins anymore.